- -
UserInfo

Welcome Anonymous




Membership:
Latest: ray-green
New Today: 0
New Yesterday: 0
Overall: 934

People Online:
Members: 1
Visitors: 3
Bots: 10
Total: 14
Who Is Where:
Members:
Visitors:
01. News
02. Forums
03. Forums
 Bots:
01. Forums
02. Forums
03. Forums
04. Home
05. Login
06. Login
07. Forums
08. CPGNuCalendar
09. Forums
10. Forums
Hidden: 1
Staff Online:

No staff members are online!
We have received
39894308
page views since
July 27, 2010

Hits New Today: 19015
Hits New Yesterday: 15387

Server Time
22 November 2018 21:40:25 AEDT (GMT +11)
Mustang Technical Discussion > Mustang Projects > hybrids 1966 Coupe Project > Community Forums > Mustang Forum Australia - Mustang Tech

New PostsLast 24hrsUnanswered
Forum Index > Mustang Projects

hybrids 1966 Coupe Project Reply to topic

Go to page Previous 1, 2, 3154, 155, 156, 157, 158 159 160 Next
Author Message
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8862

0 👍 / 1 👎


Quick update.

Two runs last night - 11.7 and then 11.6
It was a very busy night because the Workshop Wars was on, so it was a lonnnng wait between runs.
Just before my third run my cooling fan stopped working - turns out I blew the ECU output. Not 100% sure why, but the engine overheated and I had to abort.

I'm happy with the time, although I was losing boost up top. Went from about 8psi at 5000 down to 5psi by 6000, where it should be more like 10-12psi.
Again not exactly sure why, but I think it's probably belt slip.

The gearbox held 3rd gear though, and now that I'm in the 11's I'm done.


View user's profilePhoto Gallery
Dwayne
Mustang Star

Offline
Joined: Jun 01, 2016
Posts: 482
Location: Radelaide

0 👍 / 0 👎


hybrid wrote
Quick update.

Two runs last night - 11.7 and then 11.6
It was a very busy night because the Workshop Wars was on, so it was a lonnnng wait between runs.
Just before my third run my cooling fan stopped working - turns out I blew the ECU output. Not 100% sure why, but the engine overheated and I had to abort.

I'm happy with the time, although I was losing boost up top. Went from about 8psi at 5000 down to 5psi by 6000, where it should be more like 10-12psi.
Again not exactly sure why, but I think it's probably belt slip.

The gearbox held 3rd gear though, and now that I'm in the 11's I'm done.


So prior gearbox issues fully sorted now with your new setup?


View user's profile
krisr
Junior Mustang

Offline
Joined: Jul 27, 2010
Posts: 76

0 👍 / 0 👎






View user's profilePhoto Gallery
jbb
Mustang Star

Offline
Joined: Aug 04, 2010
Posts: 414
Location: close to the canberra boys

0 👍 / 0 👎


krisr wrote




Should be able to bring cars up from Canberra for that one Banana Dance 🍿


View user's profile
Shaunp
Mustang King

Offline
Joined: Jul 29, 2010
Posts: 4359
Location: Brisbane Bayside

0 👍 / 0 👎


what MPH ?


View user's profile
LEEH69
Mustang Star

Offline
Joined: Aug 08, 2010
Posts: 435
Location: Brisbane, Southside

0 👍 / 0 👎


11.6 got to be happy with that Hybrid


View user's profilePhoto Gallery
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8862

0 👍 / 0 👎


Dwayne wrote
hybrid wrote
Quick update.

Two runs last night - 11.7 and then 11.6
It was a very busy night because the Workshop Wars was on, so it was a lonnnng wait between runs.
Just before my third run my cooling fan stopped working - turns out I blew the ECU output. Not 100% sure why, but the engine overheated and I had to abort.

I'm happy with the time, although I was losing boost up top. Went from about 8psi at 5000 down to 5psi by 6000, where it should be more like 10-12psi.
Again not exactly sure why, but I think it's probably belt slip.

The gearbox held 3rd gear though, and now that I'm in the 11's I'm done.


So prior gearbox issues fully sorted now with your new setup?


Yes, although it still flared a bit after the second gear change, so need to ask Silverfox about that one. Could be a accumulator or something causing that.
But 3rd gear held all the way. It was down on power though with the boost being lower.


Shaunp wrote

what MPH ?


118, which is actually lower than I have run previously. Again down to boost I think.
60' was 1.7 which isn't great, but still a lot better than my previous 2.0 and above efforts. The track was pretty grippy because of the workshop wars that night.



You can see the boost in the pic below. After 5200 it just tapers off, which is the opposite of what a centrifugal should do. The belt seemed tight enough and it didn't have that issue on the dyno. Both HP and Torque were both still climbing on the dyno when the gearbox started slipping at 5500 (over 10lbs boost).



View user's profilePhoto Gallery
Shaunp
Mustang King

Offline
Joined: Jul 29, 2010
Posts: 4359
Location: Brisbane Bayside

0 👍 / 0 👎


Belt has to be slipping on the blower, or you have a weak blow off valve coming in too early. It will go quicker yet for sure. Its not uncommon to get an NA 347 in 65 into the 11's so I reckon you can push this to sub 11.5 once the stars align a bit more.


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8862

0 👍 / 0 👎


Yeah except I'm done. 11's was the goal after I originally ran 12.1 and was so close.
The only reason I would go back would be to check whether it's fixed, but I could probably see that in street logs even.

We did think about a boost leak somewhere, but after some discussion, I don't think the boost would keep dropping like that with a leak. You'd think it would remain pretty steady considering the supercharger would be pushing more and more air as RPM went up.

So it's almost like the supercharger has stopped spinning faster due to belt slip, and because the engine is demanding more air as RPM increases, the boost is dropping.


View user's profilePhoto Gallery
Husky65
Mustang Star

Offline
Joined: Jun 21, 2015
Posts: 938
Location: sydney

0 👍 / 0 👎


Unless the boost leak was near the map sensor? Then the car is boosting but reading incorrectly.

I don't know, it's a funny one. You have so much wrap around your pulley, I'd be surprised if it's slipping at only 5200.

So here's the deal. If i beat your time in the future will you come back?


View user's profileSend e-mail
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8862

0 👍 / 0 👎


Husky65 wrote

So here's the deal. If i beat your time in the future will you come back?


No way... your setup is so much nicer. It's only a matter of time - although I think it will be tough with manual. I can't afford to compete!


View user's profilePhoto Gallery
Ausjacko
Mustang King

Offline
Joined: Aug 03, 2010
Posts: 2264
Location: Canberra

0 👍 / 0 👎


Nice work both of you.

Hybrid, 11.5 is such a nicer number. Hell, even JBB's missus ran around that in the pink car but he will tell you it was under his instruction...

Cheers
Jacko


'68 J-code GT Fastback
'67 S-code GT coupe, 'Pink Bitz' formerly known as 'Hookin' up a brother'
'69 M_____ GTS Fastback 'Blasted'

View user's profilePhoto Gallery
jbb
Mustang Star

Offline
Joined: Aug 04, 2010
Posts: 414
Location: close to the canberra boys

0 👍 / 0 👎


Jacko
that's a nasty rumour that she started because I haven't let her drive the Mustangs yet. After all how could I let her.... The Fastback is still being run in and the pink one is always driven by me. Impatient

And it wasn't 11.5 it was 11.52. Poke

I told her we could build her a mustang of her own. Snigger but she hasn't agreed yet.

cheers
jbb


Ausjacko wrote
Nice work both of you.

Hybrid, 11.5 is such a nicer number. Hell, even JBB's missus ran around that in the pink car but he will tell you it was under his instruction...

Cheers
Jacko


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8862

0 👍 / 0 👎


Krisr found this photo for me. Absolutely love that photo. Might have to buy a copy.



View user's profilePhoto Gallery
Husky65
Mustang Star

Offline
Joined: Jun 21, 2015
Posts: 938
Location: sydney

0 👍 / 0 👎


Yeah sick photo!


View user's profileSend e-mail
All times are Australia/Sydney
Go to page Previous 1, 2, 3154, 155, 156, 157, 158 159 160 Next


Jump to:

TopPostersToday
   hybrid 
 Posts: 
 3 

   nassi 
 Posts: 
 1 

   Ausjacko 
 Posts: 
 1 

LatestForumPosts
Last 10 Forum Messages
Mustrack - new version released
Last post by hybrid in GPS Tracker on Nov 22, 2018 14:17:25

Re: Now for something completely different. Mark's "Hulk"
Last post by hybrid in Other Projects on Nov 22, 2018 01:32:52

BOOSTER VAC(edited)
Last post by ozbilt in Pre 1973 on Nov 20, 2018 09:41:38

Time to start my rebuild project
Last post by Ausjacko in Mustang Projects on Nov 17, 2018 22:51:42

Project Lil Blue Coupe
Last post by Dwayne in Mustang Projects on Nov 17, 2018 08:03:12

Restoration Shops.
Last post by nassi in Other Projects on Nov 15, 2018 21:36:22

C4 transmission leak
Last post by Nuts in Pre 1973 on Nov 15, 2018 20:01:42

Finally - the Bullitt begins! :-)
Last post by mungus in Mustang Projects on Nov 13, 2018 07:45:29

Years in the making....
Last post by nassi in Mustang Projects on Nov 11, 2018 09:33:12

Edz 66 Convertible
Last post by Pinto-Pete in Mustang Projects on Nov 08, 2018 17:29:51