- -
UserInfo

Welcome Anonymous




Membership:
Latest: snake
New Today: 0
New Yesterday: 1
Overall: 929

People Online:
Members: 5
Visitors: 5
Bots: 7
Total: 17
Who Is Where:
Members:
ChuxMy Private Messages
DaveMForums
Visitors:
01. Forums
02. Forums
03. Forums
04. Forums
05. News
 Bots:
01. Forums
02. Forums
03. Downloads
04. Forums
05. Forums
06. Login
07. Forums
Hidden: 3
Staff Online:

No staff members are online!
We have received
37952261
page views since
July 27, 2010

Hits New Today: 19231
Hits New Yesterday: 52873

Server Time
16 July 2018 20:31:11 AEST (GMT +10)
Mustang Technical Discussion > Mustang Projects > LC-1 Firmware upgrade on LINUX > Community Forums > Mustang Forum Australia - Mustang Tech

New PostsLast 24hrsUnanswered
Forum Index > Mustang Projects

LC-1 Firmware upgrade on LINUX Reply to topic

Author Message
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


Hi,

So it appears my wideband controller woes could just be a firmware problem. I've downloaded new firmware but the installer is Windoze based. All my laptops run Fedora.

Does anyone know of a LINUX procedure for upgrading Innovate products?


Last edited by lukep6470 on Mon Jan 30, 2017 2:47 pm; edited 1 time in total

View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8763

0 👍 / 0 👎


Sorry, I don't run any Linux desktops any more except for my off-network box at work.
Couldn't use it to connect to my MS2 via BT the other day either.

Can you not run a windows VM to do it?


View user's profilePhoto Gallery
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


Luke if you like pop over and we can update the firmware on a windows 10 laptop here.


I will someday think of something clever to say.

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


I might take you up on that.

I'll try it with Wine first.


View user's profile
66STNG
Mustang Star

Offline
Joined: Aug 07, 2013
Posts: 620
Location: wollongong

0 👍 / 0 👎


lukep6470 wrote
I might take you up on that.

I'll try it with Wine first.


I know Beer helps me with working on the mustang, but wine??? Kinda sounds a bit woooofy..


66 basket case

View user's profileSend e-mail
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


I actually find things go a lot better when Bourbon is involved.


View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


OK so running the Innovate software on WINE is a complete bust. It just doesn't see the USB to Serial. I finally gave up and lugged a desktop PC down to the garage and ran the upgrade from it.

This seems to have fixed the problem. The wideband has worked for 3 drives now no problem so I've turned the EGO trim back on.

Also I took the car for an autotune run on Saturday and it worked fine. I did get one odd event though. Since the engine now has 500miles on it I decided to give it a bit of welly going up hill. The data log showed 72% throttle with a gear change at 4900rpm. The AFR was 10.8 obviously way too rich.

The really strange thing is that Tunerstudio totally ignored that blat during autotune. Didn't register at all. Has anyone else seen this?


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8763

0 👍 / 0 👎


No never... would have been interesting to see if a filter was engaged during that run.
You sure there is not a filter on TPS? Some people don't want to autotune WOT.


View user's profilePhoto Gallery
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


There shouldn't be as I didn't see this with the 289. I will double check.

At least it looks like my fuel system and intake will keep up with the 347?


View user's profile
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


It will also depend on how often it hits the cell. One quick blat and it is likely not hit the requirements. A few more blats might help - I am sure you will enjoy it.


I will someday think of something clever to say.

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


I'll hold off until I get the running in oil out of this motor. It is so thin I have to wait for the engine to cool before I can see it on the dipstick!!


View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


OK so the beta firmware absolutely fixed the LC1. It hasn't thrown an error since. One thing I found while datalogging was that there was a big bump at lowish load in my timing table. It was so off that it went way past pinking to a dead spot. I've wound the timing back but now have a lean misfire in the same spot so more auto tuning is needed.

Also there was an issue with autotuning and the version of Tuner Studio I was using as on one drive once the motor came up to temp tunerstudio was still stuck with min coolant blocking tuning.

The motor now has more than 600 miles on it and has normal oil in it!!


View user's profile
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


Good news Luke - nice to see it work out after all the hassle you had had.

Do you have a youtube vid of it running?


I will someday think of something clever to say.

Last edited by boofhead on Sun Feb 26, 2017 9:39 pm; edited 1 time in total

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 522
Location: Brisbane

0 👍 / 0 👎


I'll make a video soon.


View user's profile
All times are Australia/Sydney


Jump to:

TopPostersToday
   nassi 
 Posts: 
 1 

   Chux 
 Posts: 
 1 

   hybrid 
 Posts: 
 1 

   unilec5544 
 Posts: 
 1 

   lukep6470 
 Posts: 
 1 

   DavesStang 
 Posts: 
 1 

ComingEvents
There are no events scheduled in the next 14 days.
LatestForumPosts
Last 10 Forum Messages
66 Mustang Coupe Rear seat WTB
Last post by DavesStang in Wanted - Parts on Jul 16, 2018 19:30:44

rear wheel bearings
Last post by lukep6470 in Pre 1973 on Jul 16, 2018 10:58:17

Changing pages?
Last post by unilec5544 in Website Help on Jul 16, 2018 00:59:53

70 Mach 1 - Slowly
Last post by Chux in Mustang Projects on Jul 15, 2018 20:52:16

Overheating Sorted....I Hope
Last post by ants in Pre 1973 on Jul 15, 2018 20:10:02

speedo gears
Last post by Shaunp in Pre 1973 on Jul 15, 2018 19:13:03

Self driving cars
Last post by Shaunp in Pre 1973 on Jul 14, 2018 22:03:00

Explorer axles
Last post by Dwayne in Wanted - Parts on Jul 14, 2018 19:07:10

Edz 66 Convertible
Last post by Edz66Vert in Mustang Projects on Jul 14, 2018 17:51:34

68 Mustang Brake Warning Light
Last post by Ausjacko in Pre 1973 on Jul 14, 2018 17:40:41