- -
UserInfo

Welcome Anonymous




Membership:
Latest: ray-green
New Today: 0
New Yesterday: 0
Overall: 934

People Online:
Members: 0
Visitors: 1
Bots: 9
Total: 10
Who Is Where:
Visitors:
01. News
 Bots:
01. Forums
02. Forums
03. Forums
04. CPGNuCalendar
05. Forums
06. Forums
07. CPGNuCalendar
08. Forums
09. Home

Staff Online:

No staff members are online!
We have received
39850344
page views since
July 27, 2010

Hits New Today: 1597
Hits New Yesterday: 13852

Server Time
20 November 2018 02:51:33 AEDT (GMT +11)
Mustang Technical Discussion > Mustang Projects > LC-1 Firmware upgrade on LINUX > Community Forums > Mustang Forum Australia - Mustang Tech

New PostsLast 24hrsUnanswered
Forum Index > Mustang Projects

LC-1 Firmware upgrade on LINUX Reply to topic

Author Message
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


Hi,

So it appears my wideband controller woes could just be a firmware problem. I've downloaded new firmware but the installer is Windoze based. All my laptops run Fedora.

Does anyone know of a LINUX procedure for upgrading Innovate products?


Last edited by lukep6470 on Mon Jan 30, 2017 2:47 pm; edited 1 time in total

View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8859

0 👍 / 0 👎


Sorry, I don't run any Linux desktops any more except for my off-network box at work.
Couldn't use it to connect to my MS2 via BT the other day either.

Can you not run a windows VM to do it?


View user's profilePhoto Gallery
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


Luke if you like pop over and we can update the firmware on a windows 10 laptop here.


I will someday think of something clever to say.

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


I might take you up on that.

I'll try it with Wine first.


View user's profile
66STNG
Mustang Star

Offline
Joined: Aug 07, 2013
Posts: 632
Location: wollongong

0 👍 / 0 👎


lukep6470 wrote
I might take you up on that.

I'll try it with Wine first.


I know Beer helps me with working on the mustang, but wine??? Kinda sounds a bit woooofy..


66 basket case

View user's profileSend e-mail
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


I actually find things go a lot better when Bourbon is involved.


View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


OK so running the Innovate software on WINE is a complete bust. It just doesn't see the USB to Serial. I finally gave up and lugged a desktop PC down to the garage and ran the upgrade from it.

This seems to have fixed the problem. The wideband has worked for 3 drives now no problem so I've turned the EGO trim back on.

Also I took the car for an autotune run on Saturday and it worked fine. I did get one odd event though. Since the engine now has 500miles on it I decided to give it a bit of welly going up hill. The data log showed 72% throttle with a gear change at 4900rpm. The AFR was 10.8 obviously way too rich.

The really strange thing is that Tunerstudio totally ignored that blat during autotune. Didn't register at all. Has anyone else seen this?


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8859

0 👍 / 0 👎


No never... would have been interesting to see if a filter was engaged during that run.
You sure there is not a filter on TPS? Some people don't want to autotune WOT.


View user's profilePhoto Gallery
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


There shouldn't be as I didn't see this with the 289. I will double check.

At least it looks like my fuel system and intake will keep up with the 347?


View user's profile
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


It will also depend on how often it hits the cell. One quick blat and it is likely not hit the requirements. A few more blats might help - I am sure you will enjoy it.


I will someday think of something clever to say.

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


I'll hold off until I get the running in oil out of this motor. It is so thin I have to wait for the engine to cool before I can see it on the dipstick!!


View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


OK so the beta firmware absolutely fixed the LC1. It hasn't thrown an error since. One thing I found while datalogging was that there was a big bump at lowish load in my timing table. It was so off that it went way past pinking to a dead spot. I've wound the timing back but now have a lean misfire in the same spot so more auto tuning is needed.

Also there was an issue with autotuning and the version of Tuner Studio I was using as on one drive once the motor came up to temp tunerstudio was still stuck with min coolant blocking tuning.

The motor now has more than 600 miles on it and has normal oil in it!!


View user's profile
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


Good news Luke - nice to see it work out after all the hassle you had had.

Do you have a youtube vid of it running?


I will someday think of something clever to say.

Last edited by boofhead on Sun Feb 26, 2017 9:39 pm; edited 1 time in total

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 571
Location: Brisbane

0 👍 / 0 👎


I'll make a video soon.


View user's profile
All times are Australia/Sydney


Jump to:

TopPostersToday
   123abc 
 Posts: 
 2 

   ozbilt 
 Posts: 
 2 

   hybrid 
 Posts: 
 1 

   Shaunp 
 Posts: 
 1 

LatestForumPosts
Last 10 Forum Messages
BOOSTER VAC(edited)
Last post by 123abc in Pre 1973 on Nov 20, 2018 00:12:31

Re: Now for something completely different. Mark's "Hulk"
Last post by ozbilt in Other Projects on Nov 19, 2018 23:34:33

Time to start my rebuild project
Last post by Ausjacko in Mustang Projects on Nov 17, 2018 22:51:42

Project Lil Blue Coupe
Last post by Dwayne in Mustang Projects on Nov 17, 2018 08:03:12

Restoration Shops.
Last post by nassi in Other Projects on Nov 15, 2018 21:36:22

C4 transmission leak
Last post by Nuts in Pre 1973 on Nov 15, 2018 20:01:42

Finally - the Bullitt begins! :-)
Last post by mungus in Mustang Projects on Nov 13, 2018 07:45:29

Years in the making....
Last post by nassi in Mustang Projects on Nov 11, 2018 09:33:12

Edz 66 Convertible
Last post by Pinto-Pete in Mustang Projects on Nov 08, 2018 17:29:51

Lifter Clatter - New Engine
Last post by Shaunp in General Tech Advice on Nov 07, 2018 21:11:18