- -
UserInfo

Welcome Anonymous




Membership:
Latest: Rsanter
New Today: 0
New Yesterday: 0
Overall: 901

People Online:
Members: 0
Visitors: 1
Bots: 9
Total: 10
Who Is Where:
Visitors:
01. Forums
 Bots:
01. Forums
02. Forums
03. News
04. Forums
05. Forums
06. Forums
07. Forums
08. Forums
09. Home

Staff Online:

No staff members are online!
We have received
34864428
page views since
July 27, 2010

Hits New Today: 1658
Hits New Yesterday: 13512

Server Time
23 February 2018 03:35:32 AEDT (GMT +11)
Mustang Technical Discussion > Mustang Projects > LC-1 Firmware upgrade on LINUX > Community Forums > Mustang Forum Australia - Mustang Tech

View posts since last visit • View posts last 24 hours • View unanswered posts
Forum Index > Mustang Projects

LC-1 Firmware upgrade on LINUX Reply to topic

Author Message
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


Hi,

So it appears my wideband controller woes could just be a firmware problem. I've downloaded new firmware but the installer is Windoze based. All my laptops run Fedora.

Does anyone know of a LINUX procedure for upgrading Innovate products?


Last edited by lukep6470 on Mon Jan 30, 2017 2:47 pm; edited 1 time in total

View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8554

0 👍 / 0 👎


Sorry, I don't run any Linux desktops any more except for my off-network box at work.
Couldn't use it to connect to my MS2 via BT the other day either.

Can you not run a windows VM to do it?


View user's profilePhoto Gallery
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


Luke if you like pop over and we can update the firmware on a windows 10 laptop here.


I will someday think of something clever to say.

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


I might take you up on that.

I'll try it with Wine first.


View user's profile
66STNG
Mustang Star

Offline
Joined: Aug 07, 2013
Posts: 543
Location: wollongong

0 👍 / 0 👎


lukep6470 wrote
I might take you up on that.

I'll try it with Wine first.


I know Beer helps me with working on the mustang, but wine??? Kinda sounds a bit woooofy..


66 basket case

View user's profileSend e-mail
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


I actually find things go a lot better when Bourbon is involved.


View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


OK so running the Innovate software on WINE is a complete bust. It just doesn't see the USB to Serial. I finally gave up and lugged a desktop PC down to the garage and ran the upgrade from it.

This seems to have fixed the problem. The wideband has worked for 3 drives now no problem so I've turned the EGO trim back on.

Also I took the car for an autotune run on Saturday and it worked fine. I did get one odd event though. Since the engine now has 500miles on it I decided to give it a bit of welly going up hill. The data log showed 72% throttle with a gear change at 4900rpm. The AFR was 10.8 obviously way too rich.

The really strange thing is that Tunerstudio totally ignored that blat during autotune. Didn't register at all. Has anyone else seen this?


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8554

0 👍 / 0 👎


No never... would have been interesting to see if a filter was engaged during that run.
You sure there is not a filter on TPS? Some people don't want to autotune WOT.


View user's profilePhoto Gallery
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


There shouldn't be as I didn't see this with the 289. I will double check.

At least it looks like my fuel system and intake will keep up with the 347😀


View user's profile
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


It will also depend on how often it hits the cell. One quick blat and it is likely not hit the requirements. A few more blats might help - I am sure you will enjoy it.


I will someday think of something clever to say.

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


I'll hold off until I get the running in oil out of this motor. It is so thin I have to wait for the engine to cool before I can see it on the dipstick!!


View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


OK so the beta firmware absolutely fixed the LC1. It hasn't thrown an error since. One thing I found while datalogging was that there was a big bump at lowish load in my timing table. It was so off that it went way past pinking to a dead spot. I've wound the timing back but now have a lean misfire in the same spot so more auto tuning is needed.

Also there was an issue with autotuning and the version of Tuner Studio I was using as on one drive once the motor came up to temp tunerstudio was still stuck with min coolant blocking tuning.

The motor now has more than 600 miles on it and has normal oil in it!!


View user's profile
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4505
Location: Brisbane

0 👍 / 0 👎


Good news Luke - nice to see it work out after all the hassle you had had.

Do you have a youtube vid of it running?


I will someday think of something clever to say.

Last edited by boofhead on Sun Feb 26, 2017 9:39 pm; edited 1 time in total

View user's profile
lukep6470
Mustang Star

Offline
Joined: Jan 06, 2014
Posts: 464
Location: Brisbane

0 👍 / 0 👎


I'll make a video soon.


View user's profile
All times are Australia/Sydney


Jump to:

TopPostersToday
   Shayne93 
 Posts: 
 1 

   Roger 
 Posts: 
 1 

LatestForumPosts
Last 10 Forum Messages

67 FG Resto Mod
Last post by Roger in Mustang Projects on Feb 22, 2018 14:35:24

OVER HEATING AT IDLE
Last post by 123abc in Pre 1973 on Feb 21, 2018 22:20:48

Any interest in a 3000 stall AOD non lock-up converter?
Last post by hybrid in Mustang Parts for Sale on Feb 21, 2018 12:33:33

hybrids 1966 Coupe Project
Last post by hybrid in Mustang Projects on Feb 20, 2018 07:03:39

Camshaft
Last post by trav68 in Pre 1973 on Feb 19, 2018 22:36:53

Finally getting to Mrsozbilt's Mach 1
Last post by nassi in Pre 1973 on Feb 19, 2018 19:59:19

1970 wiring
Last post by 123abc in Pre 1973 on Feb 17, 2018 08:34:20

1982 RHD Mustang dashboard
Last post by albanygt40 in 1979 - 2014 on Feb 17, 2018 01:04:10

WTD 1979-1984 Fox body mustang
Last post by nassi in Wanted - Mustangs on Feb 16, 2018 23:03:47

Current issue with posting
Last post by Pinto-Pete in Website Help on Feb 13, 2018 22:25:36