- -
UserInfo

Welcome Anonymous




Membership:
Latest: v8ford70
New Today: 0
New Yesterday: 0
Overall: 890

People Online:
Members: 1
Visitors: 3
Bots: 10
Total: 14
Who Is Where:
Members:
69BossForums
Visitors:
01. Forums
02. News
03. Forums
 Bots:
01. Forums
02. Forums
03. Forums
04. Photo Gallery
05. Forums
06. Forums
07. Content
08. Forums
09. Forums
10. Home

Staff Online:

No staff members are online!
We have received
33639890
page views since
July 27, 2010

Hits New Today: 12580
Hits New Yesterday: 17268

Server Time
17 December 2017 18:57:47 AEDT (GMT +11)
Mustang Technical Discussion > Mustang Projects > hybrids 1966 Coupe Project > Community Forums > Mustang Forum Australia - Mustang Tech

View posts since last visitView posts last 24 hoursView unanswered posts
Forum Index > Mustang Projects

hybrids 1966 Coupe Project Reply to topic

Go to page Previous 1, 2, 3147, 148, 149, 150 151 152, 153 Next
Author Message
boofhead
Mustang King

Offline
Joined: Nov 02, 2010
Posts: 4470
Location: Brisbane

0 👍 / 0 👎


Like


I will someday think of something clever to say.

View user's profile
rkmiller73
Senior Mustang

Offline
Joined: Jan 02, 2013
Posts: 259
Location: Kansas, USA

0 👍 / 0 👎


Like


View user's profileVisit poster's website
Ausjacko
Mustang King

Offline
Joined: Aug 03, 2010
Posts: 2096
Location: Canberra

0 👍 / 0 👎


pretty cool (no pun) result with the meth and intake temps. Sounds nice and strong.


'68 J-code GT Fastback
'67 S-code GT coupe, 'Pink Bitz' formerly known as 'Hookin' up a brother'
'69 M_____ GTS Fastback 'Blasted'

View user's profilePhoto Gallery
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8421

0 👍 / 0 👎


Tried to drive the car today and it doesn't maintain fuel pressure as soon as I put my foot down.
Dammit... it never ends.

So need to pull the pump out and have a look. I have a feeling the POR15 might be breaking down and blocking the pump sock - the old one was a bit black in colour.
I'll also replace the main filter just to be safe.

I actually had this problem on the dyno day when I was driving home into my street, but I thought it was a vacuum lock in the tank causing it because the cap wasn't breathing.
Obviously not that.


View user's profilePhoto Gallery
ozbilt
Site Admin

Offline
Joined: Jul 27, 2010
Posts: 10325
Location: Now at the Duggo Ranch

0 👍 / 0 👎


POR 15 in the tank?


Kerry

It is easier to get older than it it is to get wiser

View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8421

0 👍 / 0 👎


Yep... I contacted them about it before hand and they said it was essentially the same as the tank sealer, so should be fine.
Not sure I agree now.

I only put it in the bottom where the coating was burned from the tank when I cut the hole for the pump, so should be easy enough to clean out if that's what it is.


View user's profilePhoto Gallery
ozbilt
Site Admin

Offline
Joined: Jul 27, 2010
Posts: 10325
Location: Now at the Duggo Ranch

0 👍 / 0 👎


The tank cream comes with a cleaner/prep you put in there first.

I now use KBS Coatings. Local guy and good to deal with.

www.kbs-coatings.com.au


Kerry

It is easier to get older than it it is to get wiser

View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8421

0 👍 / 0 👎


Yes, I had the cleaner and the "metal ready" as well. I've done a few tanks with POR-15 kits.
I don't know that this is the problem yet, but I hope it is. It's the simplest explanation.


View user's profilePhoto Gallery
Dwayne
Senior Mustang

Offline
Joined: Jun 01, 2016
Posts: 200
Location: Radelaide

0 👍 / 0 👎


Maybe the issue is that you only coated part of the tank?

That would leave an edge that could lift.


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8421

0 👍 / 0 👎


Dwayne wrote
Maybe the issue is that you only coated part of the tank?

That would leave an edge that could lift.


Yep, that was also a concern.
In hindsight, I should have cut the hole with a grinder instead of a plasma cutter.


View user's profilePhoto Gallery
ozbilt
Site Admin

Offline
Joined: Jul 27, 2010
Posts: 10325
Location: Now at the Duggo Ranch

0 👍 / 0 👎


hybrid wrote
Dwayne wrote
Maybe the issue is that you only coated part of the tank?

That would leave an edge that could lift.


Yep, that was also a concern.
In hindsight, I should have cut the hole with a grinder instead of a plasma cutter.



Ok to do with the plasma, but finish the edge by using snips. That is my method.


Kerry

It is easier to get older than it it is to get wiser

View user's profile
Shaunp
Mustang King

Offline
Joined: Jul 29, 2010
Posts: 4112
Location: Brisbane Bayside

0 👍 / 0 👎


ozbilt wrote
hybrid wrote
Dwayne wrote
Maybe the issue is that you only coated part of the tank?

That would leave an edge that could lift.


Yep, that was also a concern.
In hindsight, I should have cut the hole with a grinder instead of a plasma cutter.



Ok to do with the plasma, but finish the edge by using snips. That is my method.


Yep its like cutting roofing iron if you cut it with snips it rolls the coating over the cut edge to some degree, and there is no burning.


View user's profile
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8421

0 👍 / 0 👎


Shaunp wrote

Yep its like cutting roofing iron if you cut it with snips it rolls the coating over the cut edge to some degree, and there is no burning.


Yeah that was my problem. The plasma burnt the coating on the bottom of the tank and I could imagine it rusting.
Shouldn't have worried about it in hindsight.. new tanks aren't that expensive.

If a later one came up at the right price I might change over anyway, but problem is I cut out one side of mine to make more room for my exhaust, so it's not a trivial job even without taking into account the hole for the pump.


View user's profilePhoto Gallery
hybrid
Mustang King

Offline
Joined: Jul 27, 2010
Posts: 8421

0 👍 / 0 👎


Sock looked OK. I cleaned some crap from the tank, but it really wasn't bad.
Fuel filter seemed OK, but I will replace it anyway.

Also going to check voltage at the fuel pump tonight. If all that checks out, the regulator will be next.


View user's profilePhoto Gallery
Pinto-Pete
Mustang King

Offline
Joined: Mar 04, 2011
Posts: 2954
Location: Kilsyth

0 👍 / 0 👎


Shouldn't rust if enough fuel to cover the affected area me thinks....


I'm Batman...

Toyo Spares.
97203177.
5/89-91 Canterbury rd Kilsyth vic.
Specialist Toyota Dismantlers.

View user's profile
All times are Australia/Sydney
Go to page Previous 1, 2, 3147, 148, 149, 150 151 152, 153 Next


Jump to:

TopPostersToday
   rkmiller73 
 Posts: 
 2 

   66STNG 
 Posts: 
 2 

   Husky65 
 Posts: 
 2 

   Nuts 
 Posts: 
 1 

   cage 
 Posts: 
 1 

   StephenSLR 
 Posts: 
 1 

ComingEvents
Mon Dec 25, 2017
Event Christmas Day
 
LatestForumPosts
Last 10 Forum Messages

C4 automatic - replace with AOD or 5 speed manual
Last post by Dwayne in Pre 1973 on Dec 17, 2017 14:31:40

Nuts Goes SImple EFI
Last post by Nuts in General Tech Advice on Dec 17, 2017 07:46:57

Mustangtech Bathurst Clubhouse...
Last post by cage in Mustang Projects on Dec 16, 2017 11:39:59

Project Brandy
Last post by cage in Mustang Projects on Dec 15, 2017 16:14:55

CJ pony parts clearance
Last post by lukep6470 in Mustang Projects on Dec 15, 2017 12:05:48

Years in the making....
Last post by MNT67 in Mustang Projects on Dec 14, 2017 22:37:11

Ronin187 - pics as promised
Last post by Ronin187 in Mustang Projects on Dec 14, 2017 20:19:27

OVER HEATING AT IDLE
Last post by 123abc in Pre 1973 on Dec 14, 2017 16:08:29

Jacko's Project
Last post by rkmiller73 in Other Projects on Dec 14, 2017 06:19:55

Mile stone (for me anyway)
Last post by MustangMedic in Events on Dec 13, 2017 06:00:53

SocialMedia

Like this page? Google +1 it!